Juniper EVPN-VXLAN Centrally Routed Bridging configuration

From ppwiki
Jump to navigation Jump to search

Goal

In this tutorial we will setup a spine/leaf topology with 2 spines and 2 leaves. The goal is to configure EVPN-VXLAN centrally Routed Bridging (CRB)

What is Centrally Routed Bridging?

Centrally Routed Bridging( CRB) is just another mechanism that provides routing functionally within the EVPN-VXLAN fabric.

In the CRB design, the inter-VXLAN routing is performed by the spine devices.

Prerequisites

For this tutorial I am using :

- EVE-NG 2.0.3-112

- VQFX model: vqfx-10000 running JUNOS 19.4R1.10

- Four(4) servers

Diagram

Crb1.png

Setup and Configuration

Spine1 configuration

set system host-name qfxssw27-dfw
set interfaces xe-0/0/0 description link_leaf1
set interfaces xe-0/0/0 unit 0 family inet address 172.16.1.49/30
set interfaces xe-0/0/1 description link_leaf2
set interfaces xe-0/0/1 unit 0 family inet address 172.16.2.2/30
set interfaces em0 unit 0 family inet address 10.193.0.78/24
set interfaces irb unit 2006 proxy-macip-advertisement
set interfaces irb unit 2006 virtual-gateway-accept-data
set interfaces irb unit 2006 family inet address 10.192.80.2/22 virtual-gateway-address 10.192.80.1
set interfaces irb unit 3502 proxy-macip-advertisement
set interfaces irb unit 3502 virtual-gateway-accept-data
set interfaces irb unit 3502 family inet address 10.192.64.2/22 virtual-gateway-address 10.192.64.1
set interfaces lo0 unit 0 family inet address 10.179.0.1/32
set policy-options policy-statement EVPN-IMPORT term VNI102005 from community com2006
set policy-options policy-statement EVPN-IMPORT term VNI102005 then accept
set policy-options policy-statement EVPN-IMPORT2006 term 1 from community com2005
set policy-options policy-statement EVPN-IMPORT2006 term 1 then accept
set policy-options policy-statement PFE-ECMP then load-balance per-packet
set policy-options policy-statement send-direct term send-lo0 from protocol direct
set policy-options policy-statement send-direct term send-lo0 then accept
set policy-options community com2005 members target:64601:2
set policy-options community com2006 members target:64601:3
set routing-instances vlan2005 routing-options auto-export
set routing-instances vlan2005 instance-type vrf
set routing-instances vlan2005 interface irb.3502
set routing-instances vlan2005 route-distinguisher 10.179.0.1:2
set routing-instances vlan2005 vrf-import EVPN-IMPORT
set routing-instances vlan2005 vrf-target target:64601:2
set routing-instances vlan2006 routing-options auto-export
set routing-instances vlan2006 instance-type vrf
set routing-instances vlan2006 interface irb.2006
set routing-instances vlan2006 route-distinguisher 10.179.0.1:3
set routing-instances vlan2006 vrf-import EVPN-IMPORT2006
set routing-instances vlan2006 vrf-target target:64601:3
set routing-options static route 0.0.0.0/0 next-hop 10.193.0.1
set routing-options static route 0.0.0.0/0 no-readvertise
set routing-options forwarding-table export PFE-ECMP
set routing-options forwarding-table ecmp-fast-reroute
set routing-options router-id 10.179.0.1
set routing-options autonomous-system 64601
set protocols evpn vni-options vni 102005 vrf-target target:1:2005
set protocols evpn vni-options vni 102006 vrf-target target:1:2006
set protocols evpn encapsulation vxlan  
set protocols evpn multicast-mode ingress-replication
set protocols evpn default-gateway no-gateway-community
set protocols evpn extended-vni-list all
set protocols bgp group UNDERLAY type external
set protocols bgp group UNDERLAY mtu-discovery
set protocols bgp group UNDERLAY export send-direct
set protocols bgp group UNDERLAY local-as 65030
set protocols bgp group UNDERLAY multipath multiple-as
set protocols bgp group UNDERLAY bfd-liveness-detection minimum-interval 1000
set protocols bgp group UNDERLAY bfd-liveness-detection multiplier 3
set protocols bgp group UNDERLAY bfd-liveness-detection session-mode automatic
set protocols bgp group UNDERLAY neighbor 172.16.2.1 description leaf2
set protocols bgp group UNDERLAY neighbor 172.16.2.1 peer-as 65033
set protocols bgp group UNDERLAY neighbor 172.16.1.50 description leaf1
set protocols bgp group UNDERLAY neighbor 172.16.1.50 peer-as 65032
set protocols bgp group EVPN-IBGP type internal
set protocols bgp group EVPN-IBGP local-address 10.179.0.1
set protocols bgp group EVPN-IBGP family evpn signaling
set protocols bgp group EVPN-IBGP cluster 1.1.1.1
set protocols bgp group EVPN-IBGP multipath
set protocols bgp group EVPN-IBGP bfd-liveness-detection minimum-interval 350
set protocols bgp group EVPN-IBGP bfd-liveness-detection multiplier 3
set protocols bgp group EVPN-IBGP bfd-liveness-detection session-mode automatic
set protocols bgp group EVPN-IBGP neighbor 10.179.0.5 description lfsw01
set protocols bgp group EVPN-IBGP neighbor 10.179.0.6 description lfsw02
set protocols bgp group EVPN-IBGP neighbor 10.179.0.2 description spine2
set protocols igmp-snooping vlan default
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 10.179.0.1:1
set switch-options vrf-target target:64512:1111
set vlans private1-a-dal vlan-id 2005   
set vlans private1-a-dal l3-interface irb.3502
set vlans private1-a-dal vxlan vni 102005
set vlans private1-b-dal vlan-id 2006   
set vlans private1-b-dal l3-interface irb.2006
set vlans private1-b-dal vxlan vni 102006

Routing information from Librenms for spine1

Lib1.png

Lin2.png

Spine2 configuration

set system host-name qfxssw28-dfw
set interfaces xe-0/0/0 description link_leaf1
set interfaces xe-0/0/0 unit 0 family inet address 172.16.1.6/30
set interfaces xe-0/0/1 description link_leaf2
set interfaces xe-0/0/1 unit 0 family inet address 172.16.2.6/30
set interfaces em0 unit 0 family inet address 10.193.0.79/24
set interfaces irb unit 2006 proxy-macip-advertisement
set interfaces irb unit 2006 virtual-gateway-accept-data
set interfaces irb unit 2006 family inet address 10.192.80.3/22 virtual-gateway-address 10.192.80.1
set interfaces irb unit 3502 proxy-macip-advertisement
set interfaces irb unit 3502 virtual-gateway-accept-data
set interfaces irb unit 3502 family inet address 10.192.64.3/22 virtual-gateway-address 10.192.64.1
set interfaces lo0 unit 0 family inet address 10.179.0.2/32
set policy-options policy-statement EVPN-IMPORT term VNI102005 from community com2006
set policy-options policy-statement EVPN-IMPORT term VNI102005 then accept
set policy-options policy-statement EVPN-IMPORT2006 term 1 from community com2005
set policy-options policy-statement EVPN-IMPORT2006 term 1 then accept
set policy-options policy-statement PFE-ECMP then load-balance per-packet
set policy-options policy-statement send-direct term send-lo0 from protocol direct
set policy-options policy-statement send-direct term send-lo0 then accept
set policy-options community com2005 members target:64601:2
set policy-options community com2006 members target:64601:3
set routing-instances vlan2005 routing-options auto-export
set routing-instances vlan2005 instance-type vrf
set routing-instances vlan2005 interface irb.3502
set routing-instances vlan2005 route-distinguisher 10.179.0.1:2
set routing-instances vlan2005 vrf-import EVPN-IMPORT
set routing-instances vlan2005 vrf-target target:64601:2
set routing-instances vlan2006 routing-options auto-export
set routing-instances vlan2006 instance-type vrf
set routing-instances vlan2006 interface irb.2006
set routing-instances vlan2006 route-distinguisher 10.179.0.1:3
set routing-instances vlan2006 vrf-import EVPN-IMPORT2006
set routing-instances vlan2006 vrf-target target:64601:3
set routing-options static route 0.0.0.0/0 next-hop 10.193.0.1
set routing-options static route 0.0.0.0/0 no-readvertise
set routing-options forwarding-table export PFE-ECMP
set routing-options forwarding-table ecmp-fast-reroute
set routing-options router-id 10.179.0.2
set routing-options autonomous-system 64601
set protocols evpn vni-options vni 102005 vrf-target target:1:2005
set protocols evpn vni-options vni 102006 vrf-target target:1:2006
set protocols evpn encapsulation vxlan
set protocols evpn multicast-mode ingress-replication
set protocols evpn default-gateway no-gateway-community
set protocols evpn extended-vni-list all
set protocols bgp group UNDERLAY type external
set protocols bgp group UNDERLAY mtu-discovery
set protocols bgp group UNDERLAY export send-direct
set protocols bgp group UNDERLAY local-as 65031
set protocols bgp group UNDERLAY multipath multiple-as
set protocols bgp group UNDERLAY bfd-liveness-detection minimum-interval 1000
set protocols bgp group UNDERLAY bfd-liveness-detection multiplier 3
set protocols bgp group UNDERLAY bfd-liveness-detection session-mode automatic
set protocols bgp group UNDERLAY neighbor 172.16.1.5 description leaf1
set protocols bgp group UNDERLAY neighbor 172.16.1.5 peer-as 65032
set protocols bgp group UNDERLAY neighbor 172.16.2.5 description leaf2
set protocols bgp group UNDERLAY neighbor 172.16.2.5 peer-as 65033
set protocols bgp group UNDERLAY neighbor 172.16.3.6 description cr1
set protocols bgp group UNDERLAY neighbor 172.16.3.6 peer-as 65028
set protocols bgp group EVPN-IBGP type internal
set protocols bgp group EVPN-IBGP local-address 10.179.0.2
set protocols bgp group EVPN-IBGP family evpn signaling
set protocols bgp group EVPN-IBGP cluster 2.2.2.2
set protocols bgp group EVPN-IBGP multipath
set protocols bgp group EVPN-IBGP bfd-liveness-detection minimum-interval 350
set protocols bgp group EVPN-IBGP bfd-liveness-detection multiplier 3
set protocols bgp group EVPN-IBGP bfd-liveness-detection session-mode automatic
set protocols bgp group EVPN-IBGP neighbor 10.179.0.5 description lfsw01
set protocols bgp group EVPN-IBGP neighbor 10.179.0.6 description lfsw02
set protocols bgp group EVPN-IBGP neighbor 10.179.0.1 description spine1
set protocols igmp-snooping vlan default
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 10.179.0.2:1
set switch-options vrf-target target:64512:1111
set vlans private1-a-dal vlan-id 2005   
set vlans private1-a-dal l3-interface irb.3502
set vlans private1-a-dal vxlan vni 102005
set vlans private1-b-dal vlan-id 2006   
set vlans private1-b-dal l3-interface irb.2006
set vlans private1-b-dal vxlan vni 102006

leaf1 configuration

set system host-name qfxlsw27-dfw
set interfaces xe-0/0/0 description link_spine1
set interfaces xe-0/0/0 unit 0 family inet address 172.16.1.50/30
set interfaces xe-0/0/1 description link_spine2
set interfaces xe-0/0/1 unit 0 family inet address 172.16.1.5/30
set interfaces xe-0/0/10 description srv22
set interfaces xe-0/0/10 unit 0 family ethernet-switching interface-mode access
set interfaces xe-0/0/10 unit 0 family ethernet-switching vlan members private1-b-dal
set interfaces xe-0/0/11 description srv11
set interfaces xe-0/0/11 unit 0 family ethernet-switching interface-mode access
set interfaces xe-0/0/11 unit 0 family ethernet-switching vlan members private1-a-dal
set interfaces em0 unit 0 family inet address 10.193.0.80/24
set interfaces lo0 unit 0 family inet address 10.179.0.5/32
set policy-options policy-statement PFE-ECMP then load-balance per-packet
set policy-options policy-statement send-direct term send-lo0 from protocol direct
set policy-options policy-statement send-direct term send-lo0 then accept
set routing-options static route 0.0.0.0/0 next-hop 10.193.0.1
set routing-options static route 0.0.0.0/0 no-readvertise
set routing-options forwarding-table export PFE-ECMP
set routing-options forwarding-table ecmp-fast-reroute
set routing-options router-id 10.179.0.5
set routing-options autonomous-system 64601
set protocols evpn vni-options vni 102005 vrf-target target:1:2005
set protocols evpn vni-options vni 102006 vrf-target target:1:2006
set protocols evpn encapsulation vxlan  
set protocols evpn multicast-mode ingress-replication
set protocols evpn extended-vni-list all
set protocols bgp group UNDERLAY type external
set protocols bgp group UNDERLAY export send-direct
set protocols bgp group UNDERLAY local-as 65032
set protocols bgp group UNDERLAY multipath multiple-as
set protocols bgp group UNDERLAY bfd-liveness-detection minimum-interval 1000
set protocols bgp group UNDERLAY bfd-liveness-detection multiplier 3
set protocols bgp group UNDERLAY bfd-liveness-detection session-mode automatic
set protocols bgp group UNDERLAY neighbor 172.16.1.6 description spine2
set protocols bgp group UNDERLAY neighbor 172.16.1.6 peer-as 65031
set protocols bgp group UNDERLAY neighbor 172.16.1.49 description spine
set protocols bgp group UNDERLAY neighbor 172.16.1.49 peer-as 65030
set protocols bgp group EVPN-IBGP type internal
set protocols bgp group EVPN-IBGP local-address 10.179.0.5
set protocols bgp group EVPN-IBGP family evpn signaling
set protocols bgp group EVPN-IBGP multipath
set protocols bgp group EVPN-IBGP bfd-liveness-detection minimum-interval 350
set protocols bgp group EVPN-IBGP bfd-liveness-detection multiplier 3
set protocols bgp group EVPN-IBGP bfd-liveness-detection session-mode automatic
set protocols bgp group EVPN-IBGP neighbor 10.179.0.1 description spine1
set protocols bgp group EVPN-IBGP neighbor 10.179.0.2 description spine2
set protocols lldp disable              
set protocols lldp port-id-subtype interface-name
set protocols lldp interface all        
set protocols lldp-med interface all    
set protocols igmp-snooping vlan default
set switch-options service-id 1         
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 10.179.0.5:1
set switch-options vrf-target target:64512:1111
set vlans default vlan-id 1             
set vlans private1-a-dal vlan-id 2005   
set vlans private1-a-dal vxlan vni 102005
set vlans private1-b-dal vlan-id 2006   
set vlans private1-b-dal vxlan vni 102006

leaf2 configuration

set system host-name qfxlsw28
set interfaces xe-0/0/0 description link_spine1
set interfaces xe-0/0/0 unit 0 family inet address 172.16.2.1/30
set interfaces xe-0/0/1 description link_spine2
set interfaces xe-0/0/1 unit 0 family inet address 172.16.2.5/30
set interfaces xe-0/0/10 description srv44
set interfaces xe-0/0/10 unit 0 family ethernet-switching interface-mode access
set interfaces xe-0/0/10 unit 0 family ethernet-switching vlan members private1-b-dal
set interfaces xe-0/0/11 description srv33
set interfaces xe-0/0/11 unit 0 family ethernet-switching interface-mode access
set interfaces xe-0/0/11 unit 0 family ethernet-switching vlan members private1-a-dal
set interfaces em0 unit 0 family inet address 10.193.0.81/24
set interfaces lo0 unit 0 family inet address 10.179.0.6/32        
set policy-options policy-statement PFE-ECMP then load-balance per-packet
set policy-options policy-statement send-direct term send-lo0 from protocol direct
set policy-options policy-statement send-direct term send-lo0 then accept
set routing-options static route 0.0.0.0/0 next-hop 10.193.0.1
set routing-options static route 0.0.0.0/0 no-readvertise
set routing-options forwarding-table export PFE-ECMP
set routing-options forwarding-table ecmp-fast-reroute
set routing-options router-id 10.179.0.6
set routing-options autonomous-system 64601
set protocols evpn vni-options vni 102005 vrf-target target:1:2005
set protocols evpn vni-options vni 102006 vrf-target target:1:2006
set protocols evpn encapsulation vxlan  
set protocols evpn multicast-mode ingress-replication
set protocols evpn extended-vni-list all
set protocols bgp group UNDERLAY type external
set protocols bgp group UNDERLAY export send-direct
set protocols bgp group UNDERLAY local-as 65033
set protocols bgp group UNDERLAY multipath multiple-as
set protocols bgp group UNDERLAY bfd-liveness-detection minimum-interval 1000
set protocols bgp group UNDERLAY bfd-liveness-detection multiplier 3
set protocols bgp group UNDERLAY bfd-liveness-detection session-mode automatic
set protocols bgp group UNDERLAY neighbor 172.16.2.2 description spine1
set protocols bgp group UNDERLAY neighbor 172.16.2.2 peer-as 65030
set protocols bgp group UNDERLAY neighbor 172.16.2.6 description spine2
set protocols bgp group UNDERLAY neighbor 172.16.2.6 peer-as 65031
set protocols bgp group EVPN-IBGP type internal
set protocols bgp group EVPN-IBGP local-address 10.179.0.6
set protocols bgp group EVPN-IBGP family evpn signaling
set protocols bgp group EVPN-IBGP multipath
set protocols bgp group EVPN-IBGP bfd-liveness-detection minimum-interval 350
set protocols bgp group EVPN-IBGP bfd-liveness-detection multiplier 3
set protocols bgp group EVPN-IBGP bfd-liveness-detection session-mode automatic
set protocols bgp group EVPN-IBGP neighbor 10.179.0.1 description spsw01
set protocols bgp group EVPN-IBGP neighbor 10.179.0.2 description spsw02
set protocols lldp disable              
set protocols lldp port-id-subtype interface-name
set protocols lldp interface all        
set protocols lldp-med interface all    
set protocols igmp-snooping vlan default
set switch-options service-id 1         
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 10.179.0.6:1
set switch-options vrf-target target:64512:1111         
set vlans private1-a-dal vlan-id 2005   
set vlans private1-a-dal vxlan vni 102005
set vlans private1-b-dal vlan-id 2006   
set vlans private1-b-dal vxlan vni 102006

Verification

IRB interface on spine1

root@qfxssw27-dfw> show interfaces irb   
Physical interface: irb, Enabled, Physical link is Up
 Interface index: 640, SNMP ifIndex: 505
 Type: Ethernet, Link-level type: Ethernet, MTU: 1514
 Device flags   : Present Running
 Interface flags: SNMP-Traps
 Link type      : Full-Duplex
 Link flags     : None
 Current address: 02:05:86:71:6b:00, Hardware address: 02:05:86:71:6b:00
 Last flapped   : Never
   Input packets : 0
   Output packets: 0
 Logical interface irb.2006 (Index 576) (SNMP ifIndex 551)
   Flags: Up SNMP-Traps 0x4000 Encapsulation: ENET2
   Bandwidth: 1Gbps
   Routing Instance: default-switch Bridging Domain: private1-b-dal
   Input packets : 87543
   Output packets: 146050
   Protocol inet, MTU: 1514
   Max nh cache: 75000, New hold nh limit: 75000, Curr nh cnt: 2, Curr new hold cnt: 0, NH drop cnt: 0
     Flags: Sendbcast-pkt-to-re, Is-Primary
       Destination: 10.192.80/22, Local: 10.192.80.1, Broadcast: 10.192.83.255
     Addresses, Flags: Is-Default Is-Preferred Is-Primary
       Destination: 10.192.80/22, Local: 10.192.80.2, Broadcast: 10.192.83.255
 Logical interface irb.3502 (Index 574) (SNMP ifIndex 547)
   Flags: Up SNMP-Traps 0x4004000 Encapsulation: ENET2
   Bandwidth: 1Gbps
   Routing Instance: default-switch Bridging Domain: private1-a-dal
   Input packets : 163473
   Output packets: 224247
   Protocol inet, MTU: 1514
   Max nh cache: 75000, New hold nh limit: 75000, Curr nh cnt: 2, Curr new hold cnt: 0, NH drop cnt: 0
     Flags: Sendbcast-pkt-to-re, Is-Primary
       Destination: 10.192.64/22, Local: 10.192.64.1, Broadcast: 10.192.67.255
     Addresses, Flags: Is-Default Is-Preferred Is-Primary
       Destination: 10.192.64/22, Local: 10.192.64.2, Broadcast: 10.192.67.255

Routing Instances

root@qfxssw27-dfw> show route instance vlan2005 extensive    
vlan2005:
 Router ID: 10.192.64.2
 Type: vrf               State: Active        
 Interfaces:
   irb.3502
 Route-distinguisher: 10.179.0.1:2
 Vrf-import: [ EVPN-IMPORT ]
 Vrf-export: [ __vrf-export-vlan2005-internal__ ]
 Vrf-export-target: [ target:64601:2 ]
 Fast-reroute-priority: low
 Tables:
   vlan2005.inet.0        : 6 routes (6 active, 0 holddown, 0 hidden)
   vlan2005.iso.0         : 0 routes (0 active, 0 holddown, 0 hidden)
   vlan2005.inet6.0       : 1 routes (1 active, 0 holddown, 0 hidden)
   vlan2005.mdt.0         : 0 routes (0 active, 0 holddown, 0 hidden)
root@qfxssw27-dfw> show route instance vlan2006 extensive    
vlan2006:
 Router ID: 10.192.80.2
 Type: vrf               State: Active        
 Interfaces:
   irb.2006
 Route-distinguisher: 10.179.0.1:3
 Vrf-import: [ EVPN-IMPORT2006 ]
 Vrf-export: [ __vrf-export-vlan2006-internal__ ]
 Vrf-export-target: [ target:64601:3 ]
 Fast-reroute-priority: low
 Tables:
   vlan2006.inet.0        : 6 routes (6 active, 0 holddown, 0 hidden)
   vlan2006.iso.0         : 0 routes (0 active, 0 holddown, 0 hidden)
   vlan2006.inet6.0       : 1 routes (1 active, 0 holddown, 0 hidden)
   vlan2006.mdt.0         : 0 routes (0 active, 0 holddown, 0 hidden)

Dynamic MAC Addresses Learning on leaf1

root@qfxlsw27-dfw> show ethernet-switching table

MAC flags (S - static MAC, D - dynamic MAC, L - locally learned, P - Persistent static

          SE - statistics enabled, NM - non configured MAC, R - remote PE MAC, O - ovsdb MAC)


Ethernet switching table : 10 entries, 10 learned
Routing instance : default-switch
  Vlan                MAC                 MAC      Logical                Active
  name                address             flags    interface              source
  private1-a-dal      00:00:5e:00:01:01   DR       esi.1760               05:00:00:fc:59:00:01:8e:75:00 
  private1-a-dal      00:50:00:00:15:00   D        xe-0/0/11.0          
  private1-a-dal      00:50:00:00:17:00   D        vtep.32771             10.179.0.6                    
  private1-a-dal      02:05:86:71:6b:00   D        vtep.32769             10.179.0.1                    
  private1-a-dal      02:05:86:71:cc:00   D        vtep.32770             10.179.0.2                    
  private1-b-dal      00:00:5e:00:01:01   DR       esi.1759               05:00:00:fc:59:00:01:8e:76:00 
  private1-b-dal      00:50:00:00:16:00   D        xe-0/0/10.0          
  private1-b-dal      00:50:00:00:18:00   D        vtep.32771             10.179.0.6                    
  private1-b-dal      02:05:86:71:6b:00   D        vtep.32769             10.179.0.1                    
  private1-b-dal      02:05:86:71:cc:00   D        vtep.32770             10.179.0.2            

Routes in the Routing Instances

root@qfxssw27-dfw> show route table vlan2005.inet.0        
vlan2005.inet.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
10.192.64.0/22     *[Direct/0] 12:14:26
                   >  via irb.3502
10.192.64.1/32     *[Local/0] 12:14:26
                      Local via irb.3502
10.192.64.2/32     *[Local/0] 12:14:26
                      Local via irb.3502
10.192.80.0/22     *[Direct/0] 12:14:26
                   >  via irb.2006
10.192.80.1/32     *[Local/0] 12:14:26
                      Local via irb.2006
10.192.80.2/32     *[Local/0] 12:14:26
                      Local via irb.2006
root@qfxssw27-dfw> show route table vlan2006.inet.0    
vlan2006.inet.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
10.192.64.0/22     *[Direct/0] 12:14:54
                   >  via irb.3502
10.192.64.1/32     *[Local/0] 12:14:54
                      Local via irb.3502
10.192.64.2/32     *[Local/0] 12:14:54
                      Local via irb.3502
10.192.80.0/22     *[Direct/0] 12:14:54
                   >  via irb.2006
10.192.80.1/32     *[Local/0] 12:14:54
                      Local via irb.2006
10.192.80.2/32     *[Local/0] 12:14:54
                      Local via irb.2006

Connectivity with Route Leaking

From server srv11 on leaf1 in vlan private1-a-dal we are going to ping server srv44 on leaf2 in vlan private1-b-dal

Ping1.png

Remove Route Leaking

In case that you don't want for servers in VLAN private1-a-dal to communicate with servers in VALN private1-b-dal and the other way around, you will have to remove some settings under policy and routing instance on both spine switches.

Settings to remove on spine1
set policy-options policy-statement EVPN-IMPORT term VNI102005 from community com2006
set policy-options policy-statement EVPN-IMPORT term VNI102005 then accept
set policy-options policy-statement EVPN-IMPORT2006 term 1 from community com2005
set policy-options policy-statement EVPN-IMPORT2006 term 1 then accept
set policy-options community com2005 members target:64601:2
set policy-options community com2006 members target:64601:3
set routing-instances vlan2005 routing-options auto-export
set routing-instances vlan2005 vrf-import EVPN-IMPORT
set routing-instances vlan2006 routing-options auto-export
set routing-instances vlan2006 vrf-import EVPN-IMPORT2006
Settings to remove on spine2
set policy-options policy-statement EVPN-IMPORT term VNI102005 from community com2006
set policy-options policy-statement EVPN-IMPORT term VNI102005 then accept
set policy-options policy-statement EVPN-IMPORT2006 term 1 from community com2005
set policy-options policy-statement EVPN-IMPORT2006 term 1 then accept
set policy-options community com2005 members target:64601:2
set policy-options community com2006 members target:64601:3
set routing-instances vlan2005 routing-options auto-export
set routing-instances vlan2005 vrf-import EVPN-IMPORT
set routing-instances vlan2006 routing-options auto-export
set routing-instances vlan2006 vrf-import EVPN-IMPORT2006

References

https://blogs.juniper.net/en-us/enterprise-cloud-and-transformation/exploring-evpn-vxlan-overlay-architectures-centrally-routed-bridging