Juniper ESI-LAG

From ppwiki
Jump to navigation Jump to search

Goal

In this tutorial we are going to to setup ESI-LAG (Ethernet Switch Identifier - Link Aggregation Group). According to Juniper: "ESI link aggregation groups (ESI-LAGs) enable one or more client devices to form a logical link aggregation group (LAG) interface with the peers". Once setup, the yellow VLAN will talk to red VLAN and the white VLAN will talk to the blue VLAN. But yellow and red will not be able to talk to white and blue.

Prerequisites

For this tutorial I will be using :

- EVE-NG 2.0.3-112

- VQFX model: vqfx-10000 running JUNOS 19.4R1.10 for spines and leaves

- Debian VM's servers

Diagram

Esi-lag.png

Setup and configuration

network info
Devices Role lo.0 IP ae0 IP mgmt AS
cc1 core swtich1 10.179.1.1/32 172.16.3.1/30 10.193.0.105/24 64701
cc2 core switch2 10.179.1.2/32 172.16.3.2/30 10.193.0.106/24 64701
sw1 switch 1 10.179.1.4/32 10.193.0.108/24
sw2 switch 2 10.179.1.3/32 10.193.0.107/24

core switch 1 configuration

set chassis aggregated-devices ethernet device-count 3
set interfaces xe-0/0/0 description link_leaf1_xe-0/0/0
set interfaces xe-0/0/0 gigether-options 802.3ad ae1
set interfaces xe-0/0/1 description link_leaf2_xe-0/0/0
set interfaces xe-0/0/1 gigether-options 802.3ad ae2
set interfaces xe-0/0/10 gigether-options 802.3ad ae0
set interfaces xe-0/0/11 gigether-options 802.3ad ae0
set interfaces ae0 description link_spine2
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic fast
set interfaces ae0 unit 0 family inet address 172.16.3.1/30
set interfaces ae1 description leaf1_ae1
set interfaces ae1 mtu 9192             
set interfaces ae1 esi 00:00:00:ab:cd:00:01:00:00:01
set interfaces ae1 esi all-active       
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp periodic fast
set interfaces ae1 aggregated-ether-options lacp system-id 00:11:00:00:00:01
set interfaces ae1 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan members private1-a-dfw
set interfaces ae1 unit 0 family ethernet-switching vlan members private1-b-dfw
set interfaces ae1 unit 0 family ethernet-switching vlan members private1-c-dfw
set interfaces ae1 unit 0 family ethernet-switching vlan members private1-d-dfw
set interfaces ae2 mtu 9192             
set interfaces ae2 esi 00:00:00:ab:cd:00:02:00:00:02
set interfaces ae2 esi all-active       
set interfaces ae2 aggregated-ether-options lacp active
set interfaces ae2 aggregated-ether-options lacp periodic fast
set interfaces ae2 aggregated-ether-options lacp system-id 00:22:00:00:00:02
set interfaces ae2 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae2 unit 0 family ethernet-switching vlan members private1-a-dfw
set interfaces ae2 unit 0 family ethernet-switching vlan members private1-b-dfw
set interfaces ae2 unit 0 family ethernet-switching vlan members private1-c-dfw
set interfaces ae2 unit 0 family ethernet-switching vlan members private1-d-dfw
set interfaces em0 unit 0 family inet address 10.193.0.105/24
set interfaces em1 unit 0 family inet address 169.254.0.2/24
set interfaces irb unit 20 family inet address 10.192.144.3/22 virtual-gateway-address 10.192.144.1
set interfaces irb unit 30 family inet address 10.192.160.3/22 virtual-gateway-address 10.192.160.1
set interfaces irb unit 40 family inet address 10.192.176.3/22 virtual-gateway-address 10.192.176.1
set interfaces irb unit 50 family inet address 10.192.192.3/22 virtual-gateway-address 10.192.192.1
set interfaces lo0 unit 0 family inet address 10.179.1.1/32
set snmp location dfw                   
set snmp filter-interfaces interfaces "^.*\.0$"
set snmp community changeme authorization read-only
set snmp community changeme routing-instance mgmt_junos
set snmp routing-instance-access             
set forwarding-options storm-control-profiles default all
set policy-options policy-statement EVPN-IMPORT term VNI5020 from community com30
set policy-options policy-statement EVPN-IMPORT term VNI5020 from community com50
set policy-options policy-statement EVPN-IMPORT term VNI5020 then accept
set policy-options policy-statement EVPN-IMPORT30 term VNI5030 from community com20
set policy-options policy-statement EVPN-IMPORT30 term VNI5030 then accept
set policy-options policy-statement EVPN-IMPORT50 term VNI5050 from community com20
set policy-options policy-statement EVPN-IMPORT50 term VNI5050 then accept
set policy-options community com20 members target:64701:20
set policy-options community com30 members target:64701:30
set policy-options community com50 members target:64701:50
set routing-instances mgmt_junos routing-options static route 0.0.0.0/0 next-hop 10.193.0.1
set routing-instances vlan20 routing-options auto-export
set routing-instances vlan20 instance-type vrf
set routing-instances vlan20 interface irb.20
set routing-instances vlan20 route-distinguisher 10.179.1.1:101
set routing-instances vlan20 vrf-import EVPN-IMPORT
set routing-instances vlan20 vrf-target target:64701:20
set routing-instances vlan30 routing-options auto-export
set routing-instances vlan30 instance-type vrf
set routing-instances vlan30 interface irb.30
set routing-instances vlan30 route-distinguisher 10.179.1.1:102
set routing-instances vlan30 vrf-import EVPN-IMPORT30
set routing-instances vlan30 vrf-target target:64701:30
set routing-instances vlan40 routing-options auto-export
set routing-instances vlan40 instance-type vrf
set routing-instances vlan40 interface irb.40
set routing-instances vlan40 route-distinguisher 10.179.1.1:103
set routing-instances vlan40 vrf-target target:64701:40
set routing-instances vlan50 routing-options auto-export
set routing-instances vlan50 instance-type vrf
set routing-instances vlan50 interface irb.50
set routing-instances vlan50 route-distinguisher 10.179.1.1:104
set routing-instances vlan50 vrf-import EVPN-IMPORT50
set routing-instances vlan50 vrf-target target:64701:50
set routing-options static route 0.0.0.0/0 next-hop 10.193.0.1
set routing-options static route 0.0.0.0/0 no-readvertise
set routing-options router-id 10.179.1.1
set routing-options autonomous-system 64701
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ospf area 0.0.0.0 interface ae0.0 interface-type p2p
set protocols ospf reference-bandwidth 800g
set protocols evpn encapsulation vxlan  
set protocols evpn default-gateway no-gateway-community
set protocols evpn extended-vni-list all
set protocols bgp group RR-OVERLAY type internal
set protocols bgp group RR-OVERLAY local-address 10.179.1.1
set protocols bgp group RR-OVERLAY family inet any
set protocols bgp group RR-OVERLAY family inet-vpn any
set protocols bgp group RR-OVERLAY family evpn signaling
set protocols bgp group RR-OVERLAY multipath
set protocols bgp group RR-OVERLAY neighbor 10.179.1.2
set protocols lldp port-id-subtype interface-name
set protocols lldp interface all        
set protocols igmp-snooping vlan default
set protocols sflow agent-id 10.193.0.105
set protocols sflow sample-rate ingress 1000
set protocols sflow source-ip 10.193.0.105
set protocols sflow collector 10.192.48.4 udp-port 6343
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 10.179.1.1:64701
set switch-options vrf-target target:64701:9999
set switch-options vrf-target auto      
set vlans private1-a-dfw vlan-id 20     
set vlans private1-a-dfw l3-interface irb.20
set vlans private1-a-dfw vxlan vni 5020 
set vlans private1-b-dfw vlan-id 30     
set vlans private1-b-dfw l3-interface irb.30
set vlans private1-b-dfw vxlan vni 5030 
set vlans private1-c-dfw vlan-id 40     
set vlans private1-c-dfw l3-interface irb.40
set vlans private1-c-dfw vxlan vni 5040 
set vlans private1-d-dfw description Admin
set vlans private1-d-dfw vlan-id 50     
set vlans private1-d-dfw l3-interface irb.50
set vlans private1-d-dfw vxlan vni 5050

core switch 2 configuration

set chassis aggregated-devices ethernet device-count 3
set interfaces xe-0/0/0 gigether-options 802.3ad ae1
set interfaces xe-0/0/1 gigether-options 802.3ad ae2
set interfaces xe-0/0/10 gigether-options 802.3ad ae0
set interfaces xe-0/0/11 gigether-options 802.3ad ae0
set interfaces ae0 aggregated-ether-options lacp active
set interfaces ae0 aggregated-ether-options lacp periodic fast
set interfaces ae0 unit 0 family inet address 172.16.3.2/30
set interfaces ae1 description leaf1_ae1
set interfaces ae1 mtu 9192             
set interfaces ae1 esi 00:00:00:ab:cd:00:01:00:00:01
set interfaces ae1 esi all-active       
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp periodic fast
set interfaces ae1 aggregated-ether-options lacp system-id 00:11:00:00:00:01
set interfaces ae1 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan members private1-a-dfw
set interfaces ae1 unit 0 family ethernet-switching vlan members private1-b-dfw
set interfaces ae1 unit 0 family ethernet-switching vlan members private1-c-dfw
set interfaces ae1 unit 0 family ethernet-switching vlan members private1-d-dfw
set interfaces ae2 mtu 9192             
set interfaces ae2 esi 00:00:00:ab:cd:00:02:00:00:02
set interfaces ae2 esi all-active       
set interfaces ae2 aggregated-ether-options lacp active
set interfaces ae2 aggregated-ether-options lacp periodic fast
set interfaces ae2 aggregated-ether-options lacp system-id 00:22:00:00:00:02
set interfaces ae2 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae2 unit 0 family ethernet-switching vlan members private1-a-dfw
set interfaces ae2 unit 0 family ethernet-switching vlan members private1-b-dfw
set interfaces ae2 unit 0 family ethernet-switching vlan members private1-c-dfw
set interfaces ae2 unit 0 family ethernet-switching vlan members private1-d-dfw
set interfaces em0 unit 0 family inet address 10.193.0.106/24
set interfaces em1 unit 0 family inet address 169.254.0.2/24
set interfaces irb unit 20 family inet address 10.192.144.2/22 virtual-gateway-address 10.192.144.1
set interfaces irb unit 30 family inet address 10.192.160.2/22 virtual-gateway-address 10.192.160.1
set interfaces irb unit 40 family inet address 10.192.176.2/22 virtual-gateway-address 10.192.176.1
set interfaces irb unit 50 family inet address 10.192.192.2/22 virtual-gateway-address 10.192.192.1
set interfaces lo0 unit 0 family inet address 10.179.1.2/32
set snmp location dfw                   
set snmp filter-interfaces interfaces "^.*\.0$"
set snmp community changeme authorization read-only
set snmp community changeme routing-instance mgmt_junos
set snmp routing-instance-access        
set forwarding-options storm-control-profiles default all
set policy-options policy-statement EVPN-IMPORT term VNI5020 from community com30
set policy-options policy-statement EVPN-IMPORT term VNI5020 then accept
set policy-options policy-statement EVPN-IMPORT30 term VNI5030 from community com20
set policy-options policy-statement EVPN-IMPORT30 term VNI5030 then accept
set policy-options policy-statement EVPN-IMPORT50 term VNI5050 from community com20
set policy-options policy-statement EVPN-IMPORT50 term VNI5050 then accept
set policy-options community com20 members targe:64701:20
set policy-options community com30 members targe:64701:30
set routing-instances mgmt_junos routing-options static route 0.0.0.0/0 next-hop 10.193.0.1
set routing-instances vlan20 routing-options auto-export
set routing-instances vlan20 instance-type vrf
set routing-instances vlan20 interface irb.20
set routing-instances vlan20 route-distinguisher 10.179.1.2:101
set routing-instances vlan20 vrf-import EVPN-IMPORT
set routing-instances vlan20 vrf-target target:64701:20
set routing-instances vlan30 routing-options auto-export
set routing-instances vlan30 instance-type vrf
set routing-instances vlan30 interface irb.30
set routing-instances vlan30 route-distinguisher 10.179.1.2:102
set routing-instances vlan30 vrf-import EVPN-IMPORT30
set routing-instances vlan30 vrf-target target:64701:30
set routing-instances vlan40 routing-options auto-export
set routing-instances vlan40 instance-type vrf
set routing-instances vlan40 interface irb.40
set routing-instances vlan40 route-distinguisher 10.179.1.2:103
set routing-instances vlan40 vrf-target target:64701:40
set routing-instances vlan50 routing-options auto-export
set routing-instances vlan50 instance-type vrf
set routing-instances vlan50 interface irb.50
set routing-instances vlan50 route-distinguisher 10.179.1.2:104
set routing-instances vlan50 vrf-import EVPN-IMPORT50
set routing-instances vlan50 vrf-target target:64701:50
set routing-options static route 0.0.0.0/0 next-hop 10.193.0.1
set routing-options static route 0.0.0.0/0 no-readvertise
set routing-options router-id 10.179.1. 2
set routing-options autonomous-system 64701
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ospf area 0.0.0.0 interface ae0.0 interface-type p2p
set protocols ospf reference-bandwidth 800g
set protocols evpn encapsulation vxlan  
set protocols evpn default-gateway do-not-advertise
set protocols evpn extended-vni-list all
set protocols bgp group RR-OVERLAY type internal
set protocols bgp group RR-OVERLAY local-address 10.179.1.2
set protocols bgp group RR-OVERLAY family inet any
set protocols bgp group RR-OVERLAY family inet-vpn any
set protocols bgp group RR-OVERLAY family evpn signaling
set protocols bgp group RR-OVERLAY multipath
set protocols bgp group RR-OVERLAY neighbor 10.179.1.1
set protocols lldp port-id-subtype interface-name
set protocols lldp interface all        
set protocols igmp-snooping vlan default
set protocols sflow agent-id 10.193.0.106
set protocols sflow collector 10.192.48.4 udp-port 6343
set switch-options vtep-source-interface lo0.0
set switch-options route-distinguisher 10.179.1.2:64701
set switch-options vrf-target target:64701:9999
set switch-options vrf-target auto      
set vlans private1-a-dfw vlan-id 20     
set vlans private1-a-dfw l3-interface irb.20
set vlans private1-a-dfw vxlan vni 5020 
set vlans private1-b-dfw vlan-id 30     
set vlans private1-b-dfw l3-interface irb.30
set vlans private1-b-dfw vxlan vni 5030 
set vlans private1-c-dfw vlan-id 40     
set vlans private1-c-dfw l3-interface irb.40
set vlans private1-c-dfw vxlan vni 5040 
set vlans private1-d-dfw description Admin
set vlans private1-d-dfw vlan-id 50     
set vlans private1-d-dfw l3-interface irb.50
set vlans private1-d-dfw vxlan vni 5050

switch 1 configuration

For switch 1 and 2 there is not much to configured just create the ae interface, setup the VLAN's and set each interface in the right VLAN.

set chassis aggregated-devices ethernet device-count 2
set interfaces xe-0/0/0 description Link_spine1-xe-0/0/0
set interfaces xe-0/0/0 gigether-options 802.3ad ae1
set interfaces xe-0/0/1 gigether-options 802.3ad ae1
set interfaces xe-0/0/8 description srv7
set interfaces xe-0/0/8 unit 0 family ethernet-switching vlan members private1-d-dfw
set interfaces xe-0/0/9 description srv5
set interfaces xe-0/0/9 unit 0 family ethernet-switching vlan members private1-c-dfw
set interfaces xe-0/0/10 unit 0 family ethernet-switching vlan members private1-b-dfw
set interfaces xe-0/0/11 unit 0 family ethernet-switching vlan members private1-a-dfw
set interfaces ae1 description core:ae1 
set interfaces ae1 mtu 9192             
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp periodic fast
set interfaces ae1 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan members private1-a-dfw
set interfaces ae1 unit 0 family ethernet-switching vlan members private1-b-dfw
set interfaces ae1 unit 0 family ethernet-switching vlan members private1-c-dfw
set interfaces ae1 unit 0 family ethernet-switching vlan members private1-d-dfw
set interfaces em0 unit 0 family inet address 10.193.0.107/24
set interfaces em1 unit 0 family inet address 169.254.0.2/24
set interfaces lo0 unit 0 family inet address 10.179.1.3/32
set vlans private1-a-dfw vlan-id 20     
set vlans private1-b-dfw vlan-id 30     
set vlans private1-c-dfw vlan-id 40     
set vlans private1-d-dfw vlan-id 50

switch 2 configuration

set chassis aggregated-devices ethernet device-count 2
set interfaces xe-0/0/0 description link_spine1_xe-0/0/1
set interfaces xe-0/0/0 gigether-options 802.3ad ae1
set interfaces xe-0/0/1 description link_spine2_xe-0/0/1
set interfaces xe-0/0/1 gigether-options 802.3ad ae1
set interfaces xe-0/0/8 description srv8
set interfaces xe-0/0/8 unit 0 family ethernet-switching vlan members private1-d-dfw
set interfaces xe-0/0/9 description srv6
set interfaces xe-0/0/9 unit 0 family ethernet-switching vlan members private1-c-dfw
set interfaces xe-0/0/10 unit 0 family ethernet-switching vlan members private1-b-dfw
set interfaces xe-0/0/11 description srv_36
set interfaces xe-0/0/11 unit 0 family ethernet-switching vlan members private1-a-dfw
set interfaces ae1 description core:ae2 
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp periodic fast
set interfaces ae1 unit 0 family ethernet-switching interface-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan members private1-a-dfw
set interfaces ae1 unit 0 family ethernet-switching vlan members private1-b-dfw
set interfaces ae1 unit 0 family ethernet-switching vlan members private1-c-dfw
set interfaces ae1 unit 0 family ethernet-switching vlan members private1-d-dfw
set interfaces em0 unit 0 family inet address 10.193.0.108/24
set interfaces em1 unit 0 family inet address 169.254.0.2/24
set interfaces lo0 unit 0 family inet address 10.179.1.4/32

Verification/Testing

  • check that ae0, ae1 and ae2 are up on cc1 and cc2
{master:0}
ppaul@cc1-dfw> show interfaces terse | match ae* 
Interface               Admin Link Proto    Local                 Remote
xe-0/0/0.0              up    up   aenet    --> ae1.0
xe-0/0/1.0              up    up   aenet    --> ae2.0
xe-0/0/10.0             up    up   aenet    --> ae0.0
xe-0/0/11.0             up    up   aenet    --> ae0.0
ae0                     up    up
ae0.0                   up    up   inet     172.16.3.1/30   
ae1                     up    up
ae1.0                   up    up   eth-switch
ae2                     up    up
ae2.0                   up    up   eth-switch
tap                     up    up
{master:0}
ppaul@scc2-dfw> show interfaces terse | match ae* 
Interface               Admin Link Proto    Local                 Remote
xe-0/0/1.0              up    up   aenet    --> ae2.0
xe-0/0/10.0             up    up   aenet    --> ae0.0
xe-0/0/11.0             up    up   aenet    --> ae0.0
ae0                     up    up
ae0.0                   up    up   inet     172.16.3.2/30   
ae1                     up    up
ae1.0                   up    up   eth-switch
ae2                     up    up
ae2.0                   up    up   eth-switch
tap                     up    up
  • Check ae1 is up on sw1 and sw2
root@lsw1-dfw> show interfaces terse | match ae* 
Interface               Admin Link Proto    Local                 Remote
xe-0/0/0.0              up    up   aenet    --> ae1.0
xe-0/0/1.0              up    up   aenet    --> ae1.0
ae1                     up    up
ae1.0                   up    up   eth-switch
tap                     up    up


root@lsw2-dfw> show interfaces terse | match ae* 
Interface               Admin Link Proto    Local                 Remote
xe-0/0/0.0              up    up   aenet    --> ae1.0
xe-0/0/1.0              up    up   aenet    --> ae1.0
ae1                     up    up
ae1.0                   up    up   eth-switch
tap                     up    up
  • Show route table on cc1 and cc2

We will be showing only the route table for cc1 and we will not be showing the default-switch.evpn.0 and bgp.evpn.0 route tables because of the size.

ppaul@sswecc1-dfw> show route 
inet.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
0.0.0.0/0          *[Static/5] 1d 22:24:52
                    >  to 10.193.0.1 via em0.0
10.179.1.1/32      *[Direct/0] 1d 22:24:53
                    >  via lo0.0
10.179.1.2/32      *[OSPF/10] 07:16:22, metric 40
                    >  to 172.16.3.2 via ae0.0
10.193.0.0/24      *[Direct/0] 1d 22:24:53
                    >  via em0.0
10.193.0.105/32    *[Local/0] 1d 22:24:53
                       Local via em0.0
169.254.0.0/24     *[Direct/0] 1d 22:24:53
                    >  via em1.0
169.254.0.2/32     *[Local/0] 1d 22:24:53
                       Local via em1.0
172.16.3.0/30      *[Direct/0] 1d 22:16:56
                    >  via ae0.0
172.16.3.1/32      *[Local/0] 1d 22:16:56
                      Local via ae0.0
224.0.0.5/32       *[OSPF/10] 1d 22:25:01, metric 1
                      MultiRecv
vlan20.inet.0: 11 destinations, 11 routes (11 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
10.192.144.0/22    *[Direct/0] 1d 22:16:43
                    >  via irb.20
10.192.144.3/32    *[Local/0] 1d 22:16:43
                       Local via irb.20
10.192.144.100/32  *[EVPN/7] 00:07:32
                    >  via irb.20
10.192.144.200/32  *[EVPN/7] 01:45:21
                    >  via irb.20
10.192.160.0/22    *[Direct/0] 1d 22:16:43
                    >  via irb.30
10.192.160.3/32    *[Local/0] 1d 22:16:43
                       Local via irb.30
10.192.160.100/32  *[EVPN/7] 00:14:47
                    >  via irb.30
10.192.160.200/32  *[EVPN/7] 01:45:21
                    >  via irb.30
10.192.192.0/22    *[Direct/0] 1d 22:16:43
                    >  via irb.50
10.192.192.3/32    *[Local/0] 1d 22:16:43
                       Local via irb.50
10.192.192.100/32  *[EVPN/7] 00:14:52
                    >  via irb.50
vlan30.inet.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both 
10.192.144.0/22    *[Direct/0] 1d 22:16:43
                    >  via irb.20       
10.192.144.3/32    *[Local/0] 1d 22:16:43
                       Local via irb.20 
10.192.144.100/32  *[EVPN/7] 00:07:32   
                    >  via irb.20       
10.192.144.200/32  *[EVPN/7] 01:45:21   
                    >  via irb.20       
10.192.160.0/22    *[Direct/0] 1d 22:16:43
                   >  via irb.30       
10.192.160.3/32    *[Local/0] 1d 22:16:43
                       Local via irb.30 
10.192.160.100/32  *[EVPN/7] 00:14:47   
                    >  via irb.30       
10.192.160.200/32  *[EVPN/7] 01:45:21   
                    >  via irb.30                                             
vlan40.inet.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both                                      
10.192.176.0/22    *[Direct/0] 1d 22:16:43
                    >  via irb.40       
10.192.176.3/32    *[Local/0] 1d 22:16:43
                       Local via irb.40 
10.192.176.100/32  *[EVPN/7] 00:14:50   
                    >  via irb.40       
10.192.176.200/32  *[EVPN/7] 01:45:03   
                    >  via irb.40                                               
vlan50.inet.0: 7 destinations, 7 routes  7 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both                                       
10.192.144.0/22    *[Direct/0] 1d 22:16:43
                    >  via irb.20       
10.192.144.3/32    *[Local/0] 1d 22:16:43
                       Local via irb.20 
10.192.144.100/32  *[EVPN/7] 00:07:32   
                    >  via irb.20       
10.192.144.200/32  *[EVPN/7] 01:45:21   
                    >  via irb.20       
10.192.192.0/22    *[Direct/0] 1d 22:16:43
                    >  via irb.50       
10.192.192.3/32    *[Local/0] 1d 22:16:43
                       Local via irb.50 
10.192.192.100/32  *[EVPN/7] 00:14:52   
                    >  via irb.50                                              
:vxlan.inet.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both                                       
10.179.1.1/32      *[Direct/0] 1d 22:24:53
                    >  via lo0.0        
10.179.1.2/32      *[Static/1] 07:16:22, metric2 40
                    >  to 172.16.3.2 via ae0.0
10.193.0.0/24      *[Direct/0] 1d 22:24:53
                    >  via em0.0        
10.193.0.105/32    *[Local/0] 1d 22:24:52
                       Local via em0.0  
169.254.0.0/24     *[Direct/0] 1d 22:24:53
                    >  via em1.0        
169.254.0.2/32     *[Local/0] 1d 22:24:53
                       Local via em1.0  
172.16.3.0/30      *[Direct/0] 1d 22:16:56
                    >  via ae0.0        
172.16.3.1/32      *[Local/0] 1d 22:16:56
                       Local via ae0.0  
_default_evpn__.evpn.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both                                       
1:10.179.1.1:0::abcd0001000001::FFFF:FFFF/192 AD/ESI        
                   *[EVPN/170] 00:14:52 
                       Indirect         
1:10.179.1.1:0::abcd0002000002::FFFF:FFFF/192 AD/ESI        
                   *[EVPN/170] 01:45:20 
                       Indirect         
1:10.179.1.1:0::050000fcbd0000139c00::FFFF:FFFF/192 AD/ESI        
                   *[EVPN/170] 1d 22:16:42
                       Indirect         
1:10.179.1.1:0::050000fcbd000013a600::FFFF:FFFF/192 AD/ESI        
                   *[EVPN/170] 1d 22:16:42
                       Indirect         
1:10.179.1.1:0::050000fcbd000013b000::FFFF:FFFF/192 AD/ESI        
                   *[EVPN/170] 1d 22:16:42
                       Indirect         
1:10.179.1.1:0::050000fcbd000013ba00::FFFF:FFFF/192 AD/ESI        
                   *[EVPN/170] 1d 22:16:42
                       Indirect         
4:10.179.1.1:0::abcd0001000001:10.179.1.1/296 ES            
                   *[EVPN/170] 00:14:53 
                       Indirect         
4:10.179.1.1:0::abcd0002000002:10.179.1.1/296 ES            
                   *[EVPN/170] 01:45:21 
                       Indirect         
4:10.179.1.2:0::abcd0001000001:10.179.1.2/296 ES            
                   *[BGP/170] 00:43:12, localpref 100, from 10.179.1.2
                      AS path: I, validation-state: unverified
                    >  to 172.16.3.2 via ae0.0
4:10.179.1.2:0::abcd0002000002:10.179.1.2/296 ES            
                   *[BGP/170] 01:55:01, localpref 100, from 10.179.1.2
                      AS path: I, validation-state: unverified
                    >  to 172.16.3.2 via ae0.0

Testing

  • From yellow VLAN on computer with IP 10.192.144.100 on SW1 ping computer on yellow VLAN with IP address 10.192.144.200 on SW2


Pingtest1.png

  • From yellow VLAN on computer with IP 10.192.144.100 on SW1 ping computer on red VLAN with IP address 10.192.160.200 on SW2

Pingtest2collas.png

This is the end of this tutorial. In the next tutorial will be discuss about Juniper collapsed design. The next tutorial will be a little bit base on this put we will add more to it such are some SRX devices that will be used to route traffic between all the Tenants. We will also configure servers multi-homing on one to the server.